Back to overview
Resolved

Some users are seeing "CSRF verification failed" errors when submitting forms in Breww

Jul 17, 2026 at 2:31pm UTC
Affected services
Breww core platform (inc. mobile app)

Resolved
Jul 17, 2026 at 3:30pm UTC

We have now confirmed the root cause of today's errors when saving or submitting information in Breww (including "CSRF verification failed" messages and failed submissions from the Breww mobile apps).

The cause was an issue at Cloudflare, one of the largest infrastructure providers on the internet, whose network sits in front of a significant proportion of the world's websites - including Breww. Their network began intermittently delivering requests to our servers with their content missing, which affected requests that save or submit information. This is why viewing pages continued to work but saving changes often failed. Cloudflare have since confirmed this incident affecting their network (https://www.cloudflarestatus.com/incidents/652w59bvnbsj) - however, they only acknowledged this several hours after the problem began, which made the issue significantly harder to identify and delayed our resolution.

Cloudflare's incident remains ongoing at the time of writing, but it no longer affects Breww. Once we traced the issue to them, we were able to implement a workaround on our side that fully resolved the errors, and we have also deployed an additional safeguard in Breww itself so that this category of upstream problem cannot affect the platform in the same way again - even while Cloudflare's issue continues, and even if a similar one were to happen again in the future.

No data held in Breww was lost or corrupted. However, if you saved or submitted something during the affected window and saw an error, that change will not have been applied - please re-try it and it will work normally now. We're really sorry for the disruption this will have caused to your day.

Created
Jul 17, 2026 at 2:31pm UTC

We are currently urgently investigating an issue causing some users to intermittently receive a "CSRF verification failed" error when submitting forms across Breww (for example when saving records or confirming actions).